Fnatic Gear Rush Mechanical Keyboard

The goods

I am referring here to product named "Rush Pro Gaming Keyboard, Brown MX Cherry Switches, UK layout".

It is quite a heavy keyboard that makes impression of well made. It is looking very minimalistic, compared to other mechanical keyboards. I love the double port usb hub included in the keyboard itself. I am happy with the dimmable key illumination, albeit in just one color - red. Wrist support also comes in handy.

The keyboard was purchased from Fnatic Gear Ltd's Amazon shop.

The issue

Just over 6 months from the purchase the keyboard went dead. It behaves as if it wasn't powered. It happened out of the blue, nothing unusual happened at the time, and no changes in configuration were made.

Steps taken to diagnose

So far, I have tested it in other USB ports (2.0 and 3.0, front and back), another PC, Windows 7 and Linux Ubuntu. Computer rebooted number of times. Both computers' drivers are up-to-date. Keyboard also used on accounts with admin privileges.

None of these attempts would make any difference so I have contacted Fnatic Gear Ltd via Amazon messaging.

The communication

Dear Sir/Madam,

I have purchased your keyboard on Amazon.co.uk just over a half a year ago.
Today it appears to fail to power up.
It happened while in-between typing (no changes in configuration).
By now, I've tried it on different USB ports (2.0 and 3.0, including via separately powered hub) as well as different machine (which worked with it fine before).
As it is within a year from purchase please advise how we are going to address this.
I suppose there is no user servicable parts inside that I can replace without voiding the warranty?
Is there a polyfuse installed in your product?

Kind Regards
Seb Walak


Please give a try those steps bellow:

  • Reboot the computer.
  • Make sure that you are using a powered USB 2.0 port (on the back of the computer).
  • Try another cluster of USB ports (on the back of the computer).
  • Verify that all drivers are up to date (Windows, Motherboard, BIOS, USB controller).
  • If possible, remove any keyboard driver not needed by the system and reboot (especially other rush drivers).
  • If possible, try to connect the rush to another computer (Windows OS preferred). *Boot as admin *Please test and run your program with Admin rights, both SW and if FW updater is used FLICK, CLUTCH and RUSH only need the software which can be found via download.fnatic.com

As per their recommendation, I have removed and reinstalled latest Rush driver (Windows only, as there is no Linux-specific driver available). This made no visible difference.

The message had an option to choose whether the answer resolved the problem or not. In this case problem remains so appropriate option was chosen.

Hello. can you please send us a video of your issue?



I found this request a bit unusual, especially for a product purchased within the last 12 months. In my experience, electronic gadgetry is usually replaced or refunded swiftly. When purchased from reputable sources, that is. This request makes the process more cumbersome than it should be. Nevertheless, let's see where it gets me. Just bear in mind that you may need to go through such hoops when you encounter an issue with their product.

Anyway, here is the (dreadfully boring) video:

Wonder how much more information they can get from it, that wasn't already communicated in writing.


UPDATE: We've ended up bouncing quite few more messages as Amazon would not allow for video files to be sent. It also seems it would blank out email addresses and urls. If there is one thing that can be learnt here is not to request video evidence if the communication channel does not allow this. Finally, after many attempts, Fnatic managed to see the video. We've only exchanged few more supplementing questions and answers and they've dispatched brand new keyboard of the same type.

It was a time consuming process but I am now happily clicking on it to edit this post.

Thanks Fnatic!